electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
Live streaming at radio.electro-music.com

  host / artist show at your time
  Antimon Antimon's Half Year Report
Please visit the chat
 Forum index » DIY Hardware and Software » ChucK programming language
miniAudicle, Chuck, and OS X Lion
Post new topic   Reply to topic Moderators: Kassen
Page 1 of 1 [6 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Author Message
usr_sbin



Joined: Sep 18, 2006
Posts: 29
Location: Laramie, WY

PostPosted: Sat Aug 13, 2011 9:35 am    Post subject: miniAudicle, Chuck, and OS X Lion
Subject description: Issues?
Reply with quote  Mark this post and the followings unread

Have nasty problems trying to run miniAudicle and/or Chuck on OS X Lion.

Just installed mA and Chuck on a MBP 13" running current version of Lion. I installed Chuck first, ran the simple check and it returned the appropriate message:

demos@DREIZEHN% chuck
[chuck]: no input files... (try --help)

...but here's the Console output from mA when I start the Virtual Machine (just before I get the pop-up warning that the Virtual Machine appears to be hanging —


[chuck]Sad2:SYSTEM): setting log level to: 2 (SYSTEM)...
[chuck]Sad2:SYSTEM): -------( Sat Aug 13 10:28:44 2011 )-------
[chuck]Sad2:SYSTEM): starting chuck virtual machine...
[chuck]Sad2:SYSTEM): | initializing virtual machine...
[chuck]Sad2:SYSTEM): | | behavior: LOOP
[chuck]Sad2:SYSTEM): | | locking down special objects...
[chuck]Sad2:SYSTEM): | | allocating shreduler...
[chuck]Sad2:SYSTEM): | | allocating messaging buffers...
[chuck]Sad2:SYSTEM): | | real-time audio: YES
[chuck]Sad2:SYSTEM): | | mode: CALLBACK
[chuck]Sad2:SYSTEM): | | sample rate: 44100
[chuck]Sad2:SYSTEM): | | buffer size: 256
[chuck]Sad2:SYSTEM): | | num buffers: 8
[chuck]Sad2:SYSTEM): | | devices adc: 0 dac: 0 (default 0)
[chuck]Sad2:SYSTEM): | | adaptive block processing: 0
[chuck]Sad2:SYSTEM): | | channels in: 0 out: 0
[chuck]Sad2:SYSTEM): | initializing compiler...
[chuck]Sad2:SYSTEM): | type dependency resolution: MANUAL
[chuck]Sad2:SYSTEM): | initializing synthesis engine...
[chuck]Sad2:SYSTEM): | | initializing 'real-time' audio...
[chuck]: (via rtaudio): one or both 'channel' parameters must be greater than zero.
[chuck]: cannot initialize audio device (try using --silent/-s)


...not sure how to troubleshoot it from this point.

Best,

~~D.

_________________
Try me ... ... said the Dalai Lama to the hot-dog vendor, "Make me one with everything."
Back to top
View user's profile Send private message Visit poster's website
Sonic



Joined: Dec 02, 2010
Posts: 84
Location: Toronto

PostPosted: Sun Sep 04, 2011 8:54 am    Post subject: Reply with quote  Mark this post and the followings unread

Code:
[chuck]: (via rtaudio): no devices found for given stream parameters:
... RtApiCore: No supported sample rates found for OS-X device (Apple Inc.: Built-in Output).
... RtApiCore: No supported sample rates found for OS-X device (Apple Inc.: Built-in Input).

[chuck]: cannot initialize audio device (try using --silent/-s)


I am also having problems running the precompiled ChucK binary under OSX Lion. I don't see any output on the console, just above error when I execute the first (sine-wave generating) program of the tutorial.

I'm going to try building from source. fingers crossed...
Back to top
View user's profile Send private message
Sonic



Joined: Dec 02, 2010
Posts: 84
Location: Toronto

PostPosted: Sun Sep 04, 2011 11:12 am    Post subject: Reply with quote  Mark this post and the followings unread

Compiled from source. Exactly the same output.

It seems that something may be hardwired to a previous OSX audio architecture. Maybe some changes can be made to the makefile? Or is it possible to try to connect to a specific audio interface in the code?

I'm not holding out much hope of assistance here, but may as well document my progress (or lack of!).
Back to top
View user's profile Send private message
barnwellsteve



Joined: Oct 30, 2011
Posts: 2
Location: San Antonio, TX

PostPosted: Sun Oct 30, 2011 9:36 pm    Post subject: audio working in lion... so far no midiout Reply with quote  Mark this post and the followings unread

I've been looking for a way to get chuck to pass user input back out as midi and I ran into this forum, which proved quite useful. I am also running MA on a 13" MBP (most recent) with Lion. I found a beta release of chuck and MA on the mailing list that got me audio support, at least so far. Here's the link:

https://lists.cs.princeton.edu/pipermail/chuck-users/2011-August/006329.html

There are two downloads there, obviously for Chuck and MA.

I don't know if my midi issues are related to Lion or my audio/midi setup, but I am so far unable to open a midi port to send midi out. Just using the standard midiout example from the documentation (pdf, no midiout examples on the website).
Back to top
View user's profile Send private message
barnwellsteve



Joined: Oct 30, 2011
Posts: 2
Location: San Antonio, TX

PostPosted: Sun Oct 30, 2011 9:56 pm    Post subject: MidiOut Working as well Reply with quote  Mark this post and the followings unread

As I suggested, it was my audio midi setup that was causing the issue. I still get a "hanging" notice when I run this:
Code:

MidiOut mout;
MidiMsg msg;

// check if port is open
if (!mout.open(0))
   me.exit();

// fill the message with data

144 => msg.data1;
112 => msg.data2;   // note
while(true)
{
   127 => msg.data3;   // velocity
   mout.send(msg);
   125::ms => now;
   0 => msg.data3;
   mout.send(msg);
   125::ms => now;
}


but I just hit cancel, brought up midi monitor and the note signals were chugging away.

So it looks like if you download those files, everything should work for you.
Back to top
View user's profile Send private message
Sonic



Joined: Dec 02, 2010
Posts: 84
Location: Toronto

PostPosted: Mon Oct 31, 2011 4:22 am    Post subject: Reply with quote  Mark this post and the followings unread

Excellent! Thanks Steve.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Moderators: Kassen
Page 1 of 1 [6 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
 Forum index » DIY Hardware and Software » ChucK programming language
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
e-m mkii

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use