electro-music.com   Dedicated to experimental electro-acoustic
and electronic music
 
    Front Page  |  Articles  |  Radio
 |  Media  |  Forum  |  Wiki  |  Links  |  Store
Forum with support of Syndicator RSS
 FAQFAQ   CalendarCalendar   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks
 RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in  Chat RoomChat Room 
 Forum index » Clavia Nord Modular » NM Classic (NM1 or G1)
Problem: connecting the NM to the computer...
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [11 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
Author Message
modulosonoro



Joined: Sep 05, 2005
Posts: 5
Location: Germany, Bavaria, Lkr. Passau

PostPosted: Mon Sep 05, 2005 10:22 am    Post subject: Problem: connecting the NM to the computer... Reply with quote  Mark this post and the followings unread

Hi everybody,

I do have a problem with my NM Keyboard and hope to get help from this forum.

I am not able to set up a working connection between my keyboard and my computer.

The facts are:
I do use a NM Keyboard with OS Version 3.03, the Modular Editor version 3.03 on a Compaq Armada notebook with Windows 2000 Professional and an Emagic Unitor8 serial port Midi interface (most recent drivers available on the Emagic homepage).
In my Sequencer Software, i do have deactivated the Midi In and Out that I have the NM PC-Jacks connected to.
But when i select these in the Editor it says "MIDI problems: could not open port."
It is definitely not a problem with the cables etc. because i successfully dumped the os update to the keyboard, so there was a data exchange in both directions...

It would be very nice if anyone could help me.
Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20735
Location: The Netherlands, Enschede
Audio files: 158
G2 patch files: 318

PostPosted: Mon Sep 05, 2005 10:35 am    Post subject: Reply with quote  Mark this post and the followings unread

Don't know if it's possible to set a compatibility mode in win2000, but under XP setting compatibility mode to win98 mode for the NM editor program solved such a "could not open port" problem for me.

And welcome to electro-music !

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
modulosonoro



Joined: Sep 05, 2005
Posts: 5
Location: Germany, Bavaria, Lkr. Passau

PostPosted: Mon Sep 05, 2005 10:43 am    Post subject: Reply with quote  Mark this post and the followings unread

As far as I know, such a compatibility mode does not exist in w2k... If i am wrong and it does, please tell me how to make the necessary settings...
Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20735
Location: The Netherlands, Enschede
Audio files: 158
G2 patch files: 318

PostPosted: Mon Sep 05, 2005 10:54 am    Post subject: Reply with quote  Mark this post and the followings unread

I'm sorry, I can't help you with win2000 as I've never used it, but I do remember some discussion about this topic on the NM mailing list and from that I got the impression that a compatibility mode is present somewhere ...

(Under win XP you right click on the executable or a shortcut to it and select the compatibility thing from the popup menu.)

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
modulosonoro



Joined: Sep 05, 2005
Posts: 5
Location: Germany, Bavaria, Lkr. Passau

PostPosted: Mon Sep 05, 2005 1:02 pm    Post subject: Reply with quote  Mark this post and the followings unread

Ok, the thing with the right click does not exist in Windows 2000. But thank you so far.

I'm still waiting for further suggestions... Smile
Back to top
View user's profile Send private message
Kassen
Janitor
Janitor


Joined: Jul 06, 2004
Posts: 7678
Location: The Hague, NL
G2 patch files: 3

PostPosted: Mon Sep 05, 2005 1:38 pm    Post subject: Reply with quote  Mark this post and the followings unread

Hmmmm. this is quite strange. Does you MIDI interface have status leds (leds that tell you when a port is sending or receiving data) and in that case, could you tell us what they do? Regardless of anything the port that the NM uses to talk to the PC should accasionally blink with a message that basically goes "I'm a NM, wanna talk?"

If the OS dump worked the editor should work too, it's bound to be something silly in some overlooked detail.

Just for kicks; you mentioned you disabled the ports in your sequencer, does it make a difference when the sequencer isn't running at all?

_________________
Kassen
Back to top
View user's profile Send private message Send e-mail Visit poster's website
modulosonoro



Joined: Sep 05, 2005
Posts: 5
Location: Germany, Bavaria, Lkr. Passau

PostPosted: Tue Sep 06, 2005 8:54 am    Post subject: Reply with quote  Mark this post and the followings unread

My MIDI interface does have status LEDs, and when the PC out is connected to the interface and the Modular is switched on, the MIDI In LED the Modular is connected to blinks all the time. At the same time the RS 232 LED says that there is a data exchange to the computer...

The thing with the sequencer... Yes, your'e probably right, I just mentioned it because it is recommended by the Clavia FAQ etc.
Back to top
View user's profile Send private message
Kassen
Janitor
Janitor


Joined: Jul 06, 2004
Posts: 7678
Location: The Hague, NL
G2 patch files: 3

PostPosted: Tue Sep 06, 2005 1:03 pm    Post subject: Reply with quote  Mark this post and the followings unread

Hmmmmm. Let's go over this one step at a time because this should just work.

Let's call the port reserved for the Nord "A" and the one that's supposed to send midi data "B".

Verify that outA on the pc goes to "ps in" on the Nord and inA is connected to "pc out", outB should go to "midi in" on the Nord and "midi out" on the Nord can go wherever you'd like it. This is where many people make mistakes; "pc in" refers to "in" on the NM, not on the pc, many people find that counter-intuitive.


I'm asuming no MIDI splitters or mergers or whatever are in sight; if they are they should be removed for now to eliminate factors. Make sure any "bypass" knobs that may be on the MIDI interface are swithced to the right setting (bypass makes it all go wrong)

Make absolutely sure the Nord OS and the editor are the same version.

Make sure that if the pc is booted up but no programs are open then the inA starts blinking as soon as you turn on the NM. Also make sure that the led for outA is off in that situation and only starts blinking when you start the editor.

If you have verified all that and it still doesn't work it might be your MIDI interface; the NM *needs* MIDI's full bandwith full time and some interfaces aren't prepared for that. Try a friend's and see what happens. You may also want to try the interface that might be hidden behind the joystick port of any consumer-level soundcards you may have installed.

(I don't think you are stupid, I just want to cheack all the little details; I made many mistakes in this in the past).

_________________
Kassen
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20735
Location: The Netherlands, Enschede
Audio files: 158
G2 patch files: 318

PostPosted: Tue Sep 06, 2005 1:45 pm    Post subject: Reply with quote  Mark this post and the followings unread

Some old stuff from the NM mailing list, maybe there is some usefull remark somewhere.

It seems to apply mostly to midisport, but there are a lot of win2000 connection trouble mails in the list archives.


Quote:
I can confirm it runs under win2000 pro with the midiman 4x4.

i had some slight problems, but after i got it back online and running, it worked fine. specifically, changing my computer from "optimize for background act" to "normal computer" made it run fine again


Quote:
There is in mine... I can choose between 95 or NT compatibility... It must be in the W2K Service Pack 1 or 2...

At 11:01 8-4-2002 +0200, you wrote:

> Thanks for that tip... but unfortunately, in win2k there is no compatibility
> mode switch :-(
>
> I went through the archives and found out that someone solved it by setting
> windows to optimize for apps, not for background tasks - that solved the
> problem for me too, *BUT*....... read www.rme-audio.de/faq/faqneud.html and
> you will find out that windows will only run low latency audio in background
> mode.
>
> Is there a different solution that does not kill my audio ???


Quote:
As far as I recall, in W2K the compatibility is no option in the
properties-dialog of a link or an *.exe-file like in XP.

In Windows 2000 it's done with a Compatibility-Wizard. Since I'm typing
this out of memory, I'm not exactly sure where it is located, but I *do*
know it's there.

And it was already in the pre-release of W2K, so I don't assume it came
as a part of a Service-Pack.

But nevertheless Service-Pack 2 is highly recommended anyway.



Quote:
Application Compatibility Tool, apcompat.exe. IIRC it is part of the
Windows 2000 Support Tools, which are installed optionally.


Quote:
I'm running the modular editor on windows 2000
every few minutes it brakes the communication between the editor and my nm...


I'm sure the problem is win2000 related...
I never had problems running the editor under xp in win98 compatibility mode...

so a friend told me to use the appcompat.exe (win2000 cd / support)
to make the nmeditor.exe working witrh w2k !!
but I get a mscvrt.dll error ---


Is anybody working with the nmeditor without any problems??

What about this dll error... can it be solved??

my midi interface is a midex8 ... worked without problems since w2k...


Quote:
forget appcompat.exe
Got to Parameters\Configuration Panel\System Folder Advanced. Click
'Performance Options' and choose 'Applications'


Quote:
I think what you are after is to enable Win2000 "Compatibility". It requires Service Pack 2, then run:

regsvr32 c:\winnt\apppatch\slayerui.dll

Create a shortcut to the NM editor, right-click the shortcut and you;ll find the "Compatibility" tab.

It doesn't improve anything here, though.

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
modulosonoro



Joined: Sep 05, 2005
Posts: 5
Location: Germany, Bavaria, Lkr. Passau

PostPosted: Sat Sep 10, 2005 2:43 am    Post subject: Reply with quote  Mark this post and the followings unread

Wow, the one with the "applications" option really made it work. But, just as it is said by anyone quoted by you, it is bad for my audio. My audio interface does strongly recommend the setting to be "background services"...
Isn't there any other, better way? Win2000 Professional is, by many, said to be the best and most stable version of Windows...
Hm, perhaps i must live with that until i get myself a new notebook with another os, or even a mac...
Back to top
View user's profile Send private message
Blue Hell
Site Admin


Joined: Apr 03, 2004
Posts: 20735
Location: The Netherlands, Enschede
Audio files: 158
G2 patch files: 318

PostPosted: Sat Sep 10, 2005 4:09 am    Post subject: Reply with quote  Mark this post and the followings unread

The quotes above were the best I could find. Your best bet would be to either use 98 or XP, a Mac will be troublesome as well.

Alternatively you could try another MIDI interface or try other drivers for your existing MIDI interface, as I think the true cause of the trouble is in the MIDI driver.

Windows XP has the advantage of being able to set compatibility on a per program base.

Windows 2000 might be the best windows, I don't know about that, but it's mostly used in office environments. But I think XP is pretty stable as well, it gives me a lot less trouble than 98 did (Both in my roll as "sysop" in the small company I work for, and at home). But I must say that SP2 did introduce some compatibility problems with some older software, I've been able to solve those though, sofar.

_________________
Jan
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic Moderators: Nord Modular Editors
Page 1 of 1 [11 Posts]
View unread posts
View new posts in the last week
Mark the topic unread :: View previous topic :: View next topic
 Forum index » Clavia Nord Modular » NM Classic (NM1 or G1)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
e-m mkii

Please support our site. If you click through and buy from
our affiliate partners, we earn a small commission.


Forum with support of Syndicator RSS
Powered by phpBB © 2001, 2005 phpBB Group
Copyright © 2003 through 2009 by electro-music.com - Conditions Of Use